CVE-2022-1188 Server-side request forgery in GitLab

Low 3.7 Published Updated

Attackers can perform blind Server-Side Request Forgery via repository mirroring, potentially accessing internal resources.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-1188?

CVE-2022-1188 is a low-severity server-side request forgery vulnerability in Gitlab Gitlab, published on 4 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 12.1 before 14.7.7, all versions starting from 14.8 before 14.8.5, all versions starting from 14.9 before 14.9.2 where a blind SSRF attack through the repository mirroring feature was possible.

Weakness: CWE-918

Which versions are affected by CVE-2022-1188?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.1.014.7.7, 14.8.5, 14.9.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-1188?

Upgrade gitlab to a fixed version for your release line: 14.7.7, 14.8.5 or 14.9.2.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2022-1188 being exploited?

There is no known exploitation of CVE-2022-1188 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-1188, GHSA-9hcx-gvx4-r4rp, UBUNTU-CVE-2022-1188.

Is CVE-2022-1188 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free