CVE-2022-1189 Information disclosure in GitLab

Low 3.1 Published Updated

An unauthorized user can read approval rules of a private project in GitLab, exposing sensitive configuration data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-1189?

CVE-2022-1189 is a low-severity vulnerability in Gitlab Gitlab, published on 4 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 12.2 before 14.7.7, all versions starting from 14.8 before 14.8.5, all versions starting from 14.9 before 14.9.2 that allowed for an unauthorised user to read the the approval rules of a private project.

Which versions are affected by CVE-2022-1189?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.2.014.7.7, 14.8.5, 14.9.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-1189?

Upgrade gitlab to a fixed version for your release line: 14.7.7, 14.8.5 or 14.9.2.

Is CVE-2022-1189 being exploited?

There is no known exploitation of CVE-2022-1189 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-1189, GHSA-2xmx-mqmp-xw34, UBUNTU-CVE-2022-1189.

Is CVE-2022-1189 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free