# CVE-2022-1191: SSRF on index.php/cobrowse/proxycss/ in livehelperchat/livehelperchat

> Server-Side Request Forgery in Live Helper Chat allows attackers to make arbitrary requests from the server, potentially accessing internal resources.

- **Severity:** High 8.7 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2022
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-livehelperchat-2022-1191, GHSA-8m92-98p8-gpmh

## What is CVE-2022-1191?

CVE-2022-1191 is a high-severity server-side request forgery vulnerability in livehelperchat/livehelperchat, published on 31 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

SSRF on index.php/cobrowse/proxycss/ in GitHub repository livehelperchat/livehelperchat prior to 3.96.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2022-1191?

1 open source package ship an affected version, including livehelperchat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `livehelperchat` | Bitnami | All versions | 3.96.0 |

Products: Livehelperchat Live Helper Chat.

## How do I fix CVE-2022-1191?

Upgrade livehelperchat to 3.96.0 or later.

## Is CVE-2022-1191 being exploited?

There is no known exploitation of CVE-2022-1191 in the wild and no public exploit code.

## Other vulnerabilities in livehelperchat/livehelperchat

- [CVE-2024-27516](https://insights.sbomify.com/CVE-2024-27516/): livehelperchat Server-Side Template Injection (critical 9.8)
- [CVE-2022-0935](https://insights.sbomify.com/CVE-2022-0935/): Host Header injection in password Reset in livehelperchat/livehelperchat (high 8.8)
- [CVE-2022-1234](https://insights.sbomify.com/CVE-2022-1234/): XSS in livehelperchat in livehelperchat/livehelperchat (high 8.8)
- [CVE-2022-1213](https://insights.sbomify.com/CVE-2022-1213/): SSRF filter bypass port 80, 433 in livehelperchat/livehelperchat (high 7.7)
- [CVE-2022-1235](https://insights.sbomify.com/CVE-2022-1235/): Weak secrethash can be brute-forced in livehelperchat/livehelperchat (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1191 and fix it if it is affected.

What it is: CVE-2022-1191 is a high-severity server-side request forgery vulnerability in livehelperchat/livehelperchat, published on 31 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-1191 in the wild and no public exploit code.

Affected packages and fixed versions:
- livehelperchat (Bitnami): affected all versions; fixed in 3.96.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1191/ (Markdown: https://insights.sbomify.com/CVE-2022-1191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1191
- OSV: https://osv.dev/vulnerability/CVE-2022-1191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1191/
Summaries are generated and may contain mistakes; the official description above is the record.
