CVE-2022-1332 Restricted custom admin role can bypass the restrictions and view the server logs and server config.json file contents
Authenticated users with restricted custom admin roles can bypass permissions to view server logs and configuration files.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-1332?
CVE-2022-1332 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 13 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
One of the API in Mattermost version 6.4.1 and earlier fails to properly protect the permissions, which allows the authenticated members with restricted custom admin role to bypass the restrictions and view the server logs and server config.json file contents.
Which versions are affected by CVE-2022-1332?
12 open source packages ship an affected version, including github.com/mattermost/mattermost-server/v6, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server/v6 Go | From 6.0.0 | 6.2.5, 6.3.5, 6.4.2 |
github.com/mattermost/mattermost-server/v6 Go | From 6.0.0 | 6.2.5 |
github.com/mattermost/mattermost-server/v6 Go | From 6.0.0 | 6.2.5 |
github.com/mattermost/mattermost-server/v6 Go | From 6.3.0 | 6.3.5 |
github.com/mattermost/mattermost-server/v6 Go | From 6.3.0 | 6.3.5 |
github.com/mattermost/mattermost-server/v6 Go | From 6.4.0 | 6.4.2 |
6 more packages
github.com/mattermost/mattermost-server/v6 Go | From 6.4.0 | 6.4.2 |
mattermost Bitnami | From 5.37.0 | 5.37.9, 6.2.5, 6.3.5, 6.4.2 |
github.com/mattermost/mattermost-server Go | All versions | None |
github.com/mattermost/mattermost-server/v5 Go | All versions | 5.37.9 |
github.com/mattermost/mattermost-server/v5 Go | All versions | 5.37.9 |
github.com/mattermost/mattermost-server/v5 Go | All versions | 5.37.9 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2022-1332?
Upgrade github.com/mattermost/mattermost-server/v6 to a fixed version for your release line: 6.2.5, 6.3.5 or 6.4.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-1332 being exploited?
There is no known exploitation of CVE-2022-1332 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as BIT-mattermost-2022-1332, GHSA-qggc-pj29-j27m, GO-2022-0616.