# CVE-2022-1332: Restricted custom admin role can bypass the restrictions and view the server logs and server config.json file contents

> Authenticated users with restricted custom admin roles can bypass permissions to view server logs and configuration files.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Apr 2022
- **Updated:** 6 Dec 2024
- **Also known as:** BIT-mattermost-2022-1332, GHSA-qggc-pj29-j27m, GO-2022-0616

## What is CVE-2022-1332?

CVE-2022-1332 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 13 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

One of the API in Mattermost version 6.4.1 and earlier fails to properly protect the permissions, which allows the authenticated members with restricted custom admin role to bypass the restrictions and view the server logs and server config.json file contents.

Weakness: CWE-269 (Improper Privilege Management), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-1332?

12 open source packages ship an affected version, including github.com/mattermost/mattermost-server/v6, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server/v6` | Go | From 6.0.0 | 6.2.5, 6.3.5, 6.4.2 |
| `github.com/mattermost/mattermost-server/v6` | Go | From 6.0.0 | 6.2.5 |
| `github.com/mattermost/mattermost-server/v6` | Go | From 6.0.0 | 6.2.5 |
| `github.com/mattermost/mattermost-server/v6` | Go | From 6.3.0 | 6.3.5 |
| `github.com/mattermost/mattermost-server/v6` | Go | From 6.3.0 | 6.3.5 |
| `github.com/mattermost/mattermost-server/v6` | Go | From 6.4.0 | 6.4.2 |
| `github.com/mattermost/mattermost-server/v6` | Go | From 6.4.0 | 6.4.2 |
| `mattermost` | Bitnami | From 5.37.0 | 5.37.9, 6.2.5, 6.3.5, 6.4.2 |
| `github.com/mattermost/mattermost-server` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | 5.37.9 |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | 5.37.9 |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | 5.37.9 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2022-1332?

Upgrade github.com/mattermost/mattermost-server/v6 to a fixed version for your release line: 6.2.5, 6.3.5 or 6.4.2.

## Is CVE-2022-1332 being exploited?

There is no known exploitation of CVE-2022-1332 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1332 and fix it if it is affected.

What it is: CVE-2022-1332 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 13 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-1332 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server/v6 (Go): affected from 6.0.0; fixed in 6.2.5, 6.3.5, 6.4.2
- github.com/mattermost/mattermost-server/v6 (Go): affected from 6.0.0; fixed in 6.2.5
- github.com/mattermost/mattermost-server/v6 (Go): affected from 6.0.0; fixed in 6.2.5
- github.com/mattermost/mattermost-server/v6 (Go): affected from 6.3.0; fixed in 6.3.5
- github.com/mattermost/mattermost-server/v6 (Go): affected from 6.3.0; fixed in 6.3.5
- github.com/mattermost/mattermost-server/v6 (Go): affected from 6.4.0; fixed in 6.4.2
- github.com/mattermost/mattermost-server/v6 (Go): affected from 6.4.0; fixed in 6.4.2
- mattermost (Bitnami): affected from 5.37.0; fixed in 5.37.9, 6.2.5, 6.3.5, 6.4.2
- github.com/mattermost/mattermost-server (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; fixed in 5.37.9
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; fixed in 5.37.9
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; fixed in 5.37.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1332/ (Markdown: https://insights.sbomify.com/CVE-2022-1332/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1332
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1332
- OSV: https://osv.dev/vulnerability/CVE-2022-1332

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1332/
Summaries are generated and may contain mistakes; the official description above is the record.
