# CVE-2022-1343: OCSP_basic_verify may incorrectly verify the response signing certificate

> Attackers can bypass OCSP certificate verification checks when the non-default OCSP_NOCHECKS flag is enabled, leading to acceptance of invalid signatures.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 May 2022
- **Updated:** 14 Oct 2026
- **Also known as:** ALPINE-CVE-2022-1343, CLEANSTART-2026-VF23025, GHSA-mfm6-r9g2-q4r7, RUSTSEC-2022-0027, UBUNTU-CVE-2022-1343

## What is CVE-2022-1343?

CVE-2022-1343 is a medium-severity vulnerability in Netapp Active Iq Unified Manager, published on 3 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The function `OCSP_basic_verify` verifies the signer certificate on an OCSP response. In the case where the (non-default) flag OCSP_NOCHECKS is used then the response will be positive (meaning a successful verification) even in the case where the response signing certificate fails to verify. It is anticipated that most users of `OCSP_basic_verify` will not use the OCSP_NOCHECKS flag. In this case the `OCSP_basic_verify` function will return a negative value (indicating a fatal error) in the case of a certificate verification failure. The normal expected return value in this case would be 0. This issue also impacts the command line OpenSSL "ocsp" application. When verifying an ocsp response with the "-no_cert_checks" option the command line application will report that the verification is successful even though it has in fact failed. In this case the incorrect successful response will also be accompanied by error messages showing the failure and contradicting the apparently successful result. Fixed in OpenSSL 3.0.3 (Affected 3.0.0,3.0.1,3.0.2).

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2022-1343?

3 open source packages ship an affected version, including openssl-src. It affects 26 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.6 |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.6 |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.6 |

Products: Netapp A250 Firmware, Netapp A700s Firmware, Netapp Active Iq Unified Manager, Netapp Aff 500f Firmware, Netapp Aff 8300 Firmware, Netapp Aff 8700 Firmware, Netapp Aff A400 Firmware, Netapp Clustered Data Ontap, Netapp Clustered Data Ontap Antivirus Connector, Netapp Fabric-Attached Storage A400 Firmware, Netapp Fas 500f Firmware, Netapp Fas 8300 Firmware, Netapp Fas 8700 Firmware, Netapp H300e Firmware, Netapp H300s Firmware, Netapp H410s Firmware, Netapp H500e Firmware, Netapp H500s Firmware, Netapp H700e Firmware, Netapp H700s Firmware and 6 more.

## How do I fix CVE-2022-1343?

Upgrade openssl-src to 300.0.6 or later.

## Is CVE-2022-1343 being exploited?

There is no known exploitation of CVE-2022-1343 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-1473](https://insights.sbomify.com/CVE-2022-1473/): Resource leakage when decoding certificates and keys (high 7.5)
- [CVE-2022-1434](https://insights.sbomify.com/CVE-2022-1434/): Incorrect MAC key used in the RC4-MD5 ciphersuite (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1343 and fix it if it is affected.

What it is: CVE-2022-1343 is a medium-severity vulnerability in Netapp Active Iq Unified Manager, published on 3 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-1343 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.6
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.6
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1343/ (Markdown: https://insights.sbomify.com/CVE-2022-1343/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1343
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1343
- OSV: https://osv.dev/vulnerability/CVE-2022-1343

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1343/
Summaries are generated and may contain mistakes; the official description above is the record.
