{"answers":{"affected":"6 open source packages ship an affected version, including github.com/mattermost/mattermost-server/v6, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-1384 in the wild and no public exploit code.","fix":"Upgrade github.com/mattermost/mattermost-server/v6 to 6.5.0 or later.","what":"CVE-2022-1384 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 19 Apr 2022. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-1384 and fix it if it is affected.\n\nWhat it is: CVE-2022-1384 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 19 Apr 2022. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-1384 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/mattermost/mattermost-server/v6 (Go): affected from 6.4.0; fixed in 6.5.0\n- github.com/mattermost/mattermost-server/v6 (Go): affected from 6.4.0; fixed in 6.5.0\n- github.com/mattermost/mattermost-server/v6 (Go): affected from 6.4.0; fixed in 6.5.0\n- mattermost (Bitnami): affected all versions; fixed in 6.5.0\n- github.com/mattermost/mattermost-server (Go): affected all versions; no fix listed\n- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-1384/ (Markdown: https://insights.sbomify.com/CVE-2022-1384/index.md)","id":"CVE-2022-1384","markdown":"https://insights.sbomify.com/CVE-2022-1384/index.md","name":"CVE-2022-1384","record":{"aliases":["BIT-mattermost-2022-1384","GHSA-32rp-q37p-jg6w","GO-2022-0576"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Mattermost collaboration platform","requires_auth":"high_privilege","summary":"Authorized users can install vulnerable old plugin versions from the Marketplace, potentially leading to code execution or security bypasses.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mattermost","cpe":[{"product":"mattermost_server","vendor":"mattermost"}],"cvss":{"score":4.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"},{"id":"CWE-477","name":"Use of Obsolete Function"}],"description":"Mattermost version 6.4.x and earlier fails to properly check the plugin version when a plugin is installed from the Marketplace, which allows an authenticated and an authorized user to install and exploit an old plugin version from the Marketplace which might have known vulnerabilities.","ecosystems":["Bitnami","Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authorized users are allowed to install old plugin versions from the Marketplace","id":"CVE-2022-1384","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"mattermost:mattermost_server","products":["mattermost:mattermost_server"],"type":"missing_authorization","year":"2022"},"n_packages":6,"n_references":1,"next":{"headline":"Invitation Email is resent as a Reminder after invalidating pending email invites","id":"CVE-2022-1385"},"packages":[{"ecosystem":"Bitnami","fixed":["6.5.0"],"introduced":["0"],"last_affected":[],"package":"mattermost","purl":"pkg:bitnami/mattermost","source":"BIT-mattermost-2022-1384"},{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","source":"GO-2022-0576"},{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-server/v5","purl":"pkg:golang/github.com/mattermost/mattermost-server/v5","source":"GO-2022-0576"},{"ecosystem":"Go","fixed":["6.5.0"],"introduced":["6.4.0"],"last_affected":[],"package":"github.com/mattermost/mattermost-server/v6","purl":null,"source":"GHSA-32rp-q37p-jg6w"},{"ecosystem":"Go","fixed":["6.5.0"],"introduced":["6.4.0"],"last_affected":[],"package":"github.com/mattermost/mattermost-server/v6","purl":"pkg:golang/github.com/mattermost/mattermost-server/v6","source":"GHSA-32rp-q37p-jg6w"},{"ecosystem":"Go","fixed":["6.5.0"],"introduced":["6.4.0"],"last_affected":[],"package":"github.com/mattermost/mattermost-server/v6","purl":"pkg:golang/github.com/mattermost/mattermost-server/v6","source":"GO-2022-0576"}],"prev":{"headline":"Heap-based Buffer Overflow in radareorg/radare2","id":"CVE-2022-1383"},"products":["Mattermost"],"published":"2022-04-19","related":[{"cvss_score":9.9,"headline":"Account takeover on OAuth/OpenID-enabled servers","id":"CVE-2025-12419","kev_date_added":null,"published":"2025-11-27"},{"cvss_score":9.9,"headline":"Account Takeover via Code Exchange Endpoint","id":"CVE-2025-12421","kev_date_added":null,"published":"2025-11-27"},{"cvss_score":9.9,"headline":"Path Traversal Leading to RCE by Any Authenticated Mattermost User","id":"CVE-2025-4981","kev_date_added":null,"published":"2025-06-20"},{"cvss_score":9.9,"headline":"Arbitrary file read via block duplication in Mattermost Boards","id":"CVE-2025-20051","kev_date_added":null,"published":"2025-02-24"},{"cvss_score":9.9,"headline":"Arbitrary file read in Mattermost Boards via import \u0026 export board archive","id":"CVE-2025-25279","kev_date_added":null,"published":"2025-02-24"},{"cvss_score":9.8,"headline":"Mattermost Server: Insufficient Password-Reset Link Invalidation","id":"CVE-2016-11074","kev_date_added":null,"published":"2020-06-19"},{"cvss_score":9.8,"headline":"Mattermost Server allows attackers to gain privileges by accessing unintended API endpoints with users' credentials","id":"CVE-2017-18885","kev_date_added":null,"published":"2020-06-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-06","vendors":["Mattermost"]},"summary":"Authorized users can install vulnerable old plugin versions from the Marketplace, potentially leading to code execution or security bypasses.","url":"https://insights.sbomify.com/CVE-2022-1384/"}