CVE-2022-1406 Information disclosure in GitLab
A Developer can read protected CI/CD variables by importing a malicious project due to improper input validation in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-1406?
CVE-2022-1406 is a medium-severity vulnerability in Gitlab Gitlab, published on 11 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper input validation in GitLab CE/EE affecting all versions from 8.12 prior to 14.8.6, all versions from 14.9.0 prior to 14.9.4, and 14.10.0 allows a Developer to read protected Group or Project CI/CD variables by importing a malicious project
Weakness: CWE-20
Which versions are affected by CVE-2022-1406?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 8.12.0 | 14.8.6, 14.9.4, 14.10.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-1406?
Upgrade gitlab to a fixed version for your release line: 14.8.6, 14.9.4 or 14.10.1.
Is CVE-2022-1406 being exploited?
There is no known exploitation of CVE-2022-1406 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-1406, GHSA-2rf4-rj3g-f4pj.