# CVE-2022-1411: Unrestructed file upload in yetiforcecompany/yetiforcecrm

> Attackers can upload malicious files to steal victim cookies and retrieve stored data, leading to account takeover in YetiForce CRM.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-pqr6-3j58-9w58

## What is CVE-2022-1411?

CVE-2022-1411 is a critical vulnerability in yetiforcecompany/yetiforcecrm, published on 5 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Unrestructed file upload in GitHub repository yetiforcecompany/yetiforcecrm prior to 6.4.0. Attacker can send malicious files to the victims is able to retrieve the stored data from the web application without that data being made safe to render in the browser and steals victim's cookie leads to account takeover.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2022-1411?

2 open source packages ship an affected version, including yetiforce/yetiforce-crm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yetiforce/yetiforce-crm` | Packagist | All versions | 6.4.0 |
| `yetiforce/yetiforce-crm` | Packagist | All versions | 6.4.0 |

Products: Yetiforce Yetiforce Customer Relationship Management.

## How do I fix CVE-2022-1411?

Upgrade yetiforce/yetiforce-crm to 6.4.0 or later.

## Is CVE-2022-1411 being exploited?

There is no known exploitation of CVE-2022-1411 in the wild and no public exploit code.

## Other vulnerabilities in yetiforcecompany/yetiforcecrm

- [CVE-2022-2890](https://insights.sbomify.com/CVE-2022-2890/): Cross-site Scripting (XSS) - Stored in yetiforcecompany/yetiforcecrm (critical 9.0)
- [CVE-2022-2829](https://insights.sbomify.com/CVE-2022-2829/): Cross-site Scripting (XSS) - Stored in yetiforcecompany/yetiforcecrm (high 8.8)
- [CVE-2022-0269](https://insights.sbomify.com/CVE-2022-0269/): Cross-Site Request Forgery (CSRF) in yetiforcecompany/yetiforcecrm (high 8.0)
- [CVE-2021-4117](https://insights.sbomify.com/CVE-2021-4117/): Business Logic Errors in yetiforcecompany/yetiforcecrm (high 7.7)
- [CVE-2021-4111](https://insights.sbomify.com/CVE-2021-4111/): Business Logic Errors in yetiforcecompany/yetiforcecrm (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1411 and fix it if it is affected.

What it is: CVE-2022-1411 is a critical vulnerability in yetiforcecompany/yetiforcecrm, published on 5 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-1411 in the wild and no public exploit code.

Affected packages and fixed versions:
- yetiforce/yetiforce-crm (Packagist): affected all versions; fixed in 6.4.0
- yetiforce/yetiforce-crm (Packagist): affected all versions; fixed in 6.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1411/ (Markdown: https://insights.sbomify.com/CVE-2022-1411/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1411
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1411
- OSV: https://osv.dev/vulnerability/CVE-2022-1411

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1411/
Summaries are generated and may contain mistakes; the official description above is the record.
