CVE-2022-1413 Information disclosure in GitLab

Medium 5.4 Published Updated

Attackers can view sensitive integration properties in the GitLab web interface due to missing input masking, potentially exposing secrets.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-1413?

CVE-2022-1413 is a medium-severity vulnerability in Gitlab Gitlab, published on 19 May 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Missing input masking in GitLab CE/EE affecting all versions starting from 1.0.2 before 14.8.6, all versions from 14.9.0 before 14.9.4, and all versions from 14.10.0 before 14.10.1 causes potentially sensitive integration properties to be disclosed in the web interface

Weakness: CWE-522

Which versions are affected by CVE-2022-1413?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 1.0.214.8.6, 14.9.4, 14.10.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-1413?

Upgrade gitlab to a fixed version for your release line: 14.8.6, 14.9.4 or 14.10.1.

Is CVE-2022-1413 being exploited?

There is no known exploitation of CVE-2022-1413 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-1413, GHSA-chvg-47qc-prxj.

Is CVE-2022-1413 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free