CVE-2022-1416 Cross-site scripting in GitLab

Medium 4.3 Published Updated

Attackers can inject malicious HTML and CSS into GitLab pipeline error messages, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-1416?

CVE-2022-1416 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 19 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Missing sanitization of data in Pipeline error messages in GitLab CE/EE affecting all versions starting from 1.0.2 before 14.8.6, all versions from 14.9.0 before 14.9.4, and all versions from 14.10.0 before 14.10.1 allows for rendering of attacker controlled HTML tags and CSS styling

Weakness: CWE-79

Which versions are affected by CVE-2022-1416?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 1.0.214.8.6, 14.9.4, 14.10.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-1416?

Upgrade gitlab to a fixed version for your release line: 14.8.6, 14.9.4 or 14.10.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-1416 being exploited?

There is no known exploitation of CVE-2022-1416 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-1416, GHSA-2h7w-85g4-9cx4.

Is CVE-2022-1416 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free