CVE-2022-1417 Missing authorization in GitLab
Non-project members can access private wiki contents via malicious CI jobs, exposing sensitive project information.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-1417?
CVE-2022-1417 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 10 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper access control in GitLab CE/EE affecting all versions starting from 8.12 before 14.8.6, all versions starting from 14.9 before 14.9.4, and all versions starting from 14.10 before 14.10.1 allows non-project members to access contents of Project Members-only Wikis via malicious CI jobs
Weakness: CWE-863
Which versions are affected by CVE-2022-1417?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 8.12.0 | 14.8.6, 14.9.4, 14.10.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-1417?
Upgrade gitlab to a fixed version for your release line: 14.8.6, 14.9.4 or 14.10.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-1417 being exploited?
There is no known exploitation of CVE-2022-1417 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-1417, GHSA-3352-m362-5wfx.