CVE-2022-1423 Missing authorization in GitLab

High 7.1 Published Updated

A malicious developer can poison CI/CD caches to execute arbitrary code in protected branches due to improper access control.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-1423?

CVE-2022-1423 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 19 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper access control in the CI/CD cache mechanism in GitLab CE/EE affecting all versions starting from 1.0.2 before 14.8.6, all versions from 14.9.0 before 14.9.4, and all versions from 14.10.0 before 14.10.1 allows a malicious actor with Developer privileges to perform cache poisoning leading to arbitrary code execution in protected branches

Weakness: CWE-862

Which versions are affected by CVE-2022-1423?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 1.0.214.8.6, 14.9.4, 14.10.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-1423?

Upgrade gitlab to a fixed version for your release line: 14.8.6, 14.9.4 or 14.10.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2022-1423 being exploited?

There is no known exploitation of CVE-2022-1423 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-1423, GHSA-2f58-3p8j-4mx4.

Is CVE-2022-1423 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free