CVE-2022-1426 Auth bypass in GitLab

Low 2.0 Published Updated

GitLab failed to properly authenticate users, allowing attackers to bypass personal access token requirements and gain unauthorized access.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-1426?

CVE-2022-1426 is a low-severity authentication bypass vulnerability in Gitlab Gitlab, published on 11 May 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab affecting all versions starting from 12.6 before 14.8.6, all versions starting from 14.9 before 14.9.4, all versions starting from 14.10 before 14.10.1. GitLab was not correctly authenticating a user that had some certain amount of information which allowed an user to authenticate without a personal access token.

Weakness: CWE-287

Which versions are affected by CVE-2022-1426?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.6.014.8.6, 14.9.4, 14.10.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-1426?

Upgrade gitlab to a fixed version for your release line: 14.8.6, 14.9.4 or 14.10.1.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2022-1426 being exploited?

There is no known exploitation of CVE-2022-1426 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-1426, GHSA-g5f4-f74v-9j97.

Is CVE-2022-1426 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free