CVE-2022-1428 Security feature bypass in GitLab
GitLab fails to enforce throttling limits for authenticated package requests, allowing attackers to bypass rate limiting protections.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-1428?
CVE-2022-1428 is a medium-severity vulnerability in Gitlab Gitlab, published on 11 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab affecting all versions before 14.8.6, all versions starting from 14.9 before 14.9.4, all versions starting from 14.10 before 14.10.1. GitLab was incorrectly verifying throttling limits for authenticated package requests which resulted in limits not being enforced.
Weakness: CWE-770
Which versions are affected by CVE-2022-1428?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | All versions | 14.8.6, 14.9.4, 14.10.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-1428?
Upgrade gitlab to a fixed version for your release line: 14.8.6, 14.9.4 or 14.10.1.
Is CVE-2022-1428 being exploited?
There is no known exploitation of CVE-2022-1428 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-1428, GHSA-976q-hmq8-mp6g.