CVE-2022-1433 Cross-site scripting in GitLab

Low 2.6 Published Updated

Attackers can execute persistent XSS payloads in GitLab due to missing cache invalidation, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-1433?

CVE-2022-1433 is a low-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 11 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab affecting all versions starting from 14.4 before 14.8.6, all versions starting from 14.9 before 14.9.4, all versions starting from 14.10 before 14.10.1. Missing invalidation of Markdown caching causes potential payloads from a previously exploitable XSS vulnerability (CVE-2022-1175) to persist and execute.

Weakness: CWE-79

Which versions are affected by CVE-2022-1433?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 14.4.014.8.6, 14.9.4, 14.10.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-1433?

Upgrade gitlab to a fixed version for your release line: 14.8.6, 14.9.4 or 14.10.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-1433 being exploited?

There is no known exploitation of CVE-2022-1433 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-1433, GHSA-jh26-hqr4-2cjg.

Is CVE-2022-1433 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free