CVE-2022-1434 Incorrect MAC key used in the RC4-MD5 ciphersuite

Medium 5.9 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2022-1434?

CVE-2022-1434 is a medium-severity vulnerability in Netapp Active Iq Unified Manager, published on 3 May 2022.

Official description

The OpenSSL 3.0 implementation of the RC4-MD5 ciphersuite incorrectly uses the AAD data as the MAC key. This makes the MAC key trivially predictable. An attacker could exploit this issue by performing a man-in-the-middle attack to modify data being sent from one endpoint to an OpenSSL 3.0 recipient such that the modified data would still pass the MAC integrity check. Note that data sent from an OpenSSL 3.0 endpoint to a non-OpenSSL 3.0 endpoint will always be rejected by the recipient and the connection will fail at that point. Many application protocols require data to be sent from the client to the server first. Therefore, in such a case, only an OpenSSL 3.0 server would be impacted when talking to a non-OpenSSL 3.0 client. If both endpoints are OpenSSL 3.0 then the attacker could modify data being sent in both directions. In this case both clients and servers could be affected, regardless of the application protocol. Note that in the absence of an attacker this bug means that an OpenSSL 3.0 endpoint communicating with a non-OpenSSL 3.0 endpoint will fail to complete the handshake when using this ciphersuite. The confidentiality of data is not impacted by this issue, i.e. an attacker cannot decrypt data that has been encrypted using this ciphersuite - they can only modify it. In order for this attack to work both endpoints must legitimately negotiate the RC4-MD5 ciphersuite. This ciphersuite is not compiled by default in OpenSSL 3.0, and is not available within the default provider or the default ciphersuite list. This ciphersuite will never be used if TLSv1.3 has been negotiated. In order for an OpenSSL 3.0 endpoint to use this ciphersuite the following must have occurred: 1) OpenSSL must have been compiled with the (non-default) compile time option enable-weak-ssl-ciphers 2) OpenSSL must have had the legacy provider explicitly loaded (either through application code or via configuration) 3) The ciphersuite must have been explicitly added to the ciphersuite list 4) The libssl security level must have been set to 0 (default is 1) 5) A version of SSL/TLS below TLSv1.3 must have been negotiated 6) Both endpoints must negotiate the RC4-MD5 ciphersuite in preference to any others that both endpoints have in common Fixed in OpenSSL 3.0.3 (Affected 3.0.0,3.0.1,3.0.2).

Weakness: CWE-327

Which versions are affected by CVE-2022-1434?

3 open source packages ship an affected version, including openssl-src. It affects 26 products.

PackageAffectedFixed in
openssl-src crates.ioFrom 300.0.0300.0.6
openssl-src crates.ioFrom 300.0.0300.0.6
openssl-src crates.ioFrom 300.0.0300.0.6

Products include Netapp A250 Firmware, Netapp A700s Firmware, Netapp Active Iq Unified Manager, Netapp Aff 500f Firmware, Netapp Aff 8300 Firmware, Netapp Aff 8700 Firmware and 20 more.

How do I fix CVE-2022-1434?

Upgrade openssl-src to 300.0.6 or later.

Is CVE-2022-1434 being exploited?

There is no known exploitation of CVE-2022-1434 in the wild and no public exploit code.

All Netapp Active Iq Unified Manager vulnerabilities

Sources

Also known as ALPINE-CVE-2022-1434, CLEANSTART-2026-TE77063, GHSA-638m-m8mh-7gw2, RUSTSEC-2022-0026, UBUNTU-CVE-2022-1434.

Is CVE-2022-1434 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free