# CVE-2022-1434: Incorrect MAC key used in the RC4-MD5 ciphersuite


- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 3 May 2022
- **Updated:** 14 Oct 2026
- **Also known as:** ALPINE-CVE-2022-1434, CLEANSTART-2026-TE77063, GHSA-638m-m8mh-7gw2, RUSTSEC-2022-0026, UBUNTU-CVE-2022-1434

## What is CVE-2022-1434?

CVE-2022-1434 is a medium-severity vulnerability in Netapp Active Iq Unified Manager, published on 3 May 2022. 

### Official description

The OpenSSL 3.0 implementation of the RC4-MD5 ciphersuite incorrectly uses the AAD data as the MAC key. This makes the MAC key trivially predictable. An attacker could exploit this issue by performing a man-in-the-middle attack to modify data being sent from one endpoint to an OpenSSL 3.0 recipient such that the modified data would still pass the MAC integrity check. Note that data sent from an OpenSSL 3.0 endpoint to a non-OpenSSL 3.0 endpoint will always be rejected by the recipient and the connection will fail at that point. Many application protocols require data to be sent from the client to the server first. Therefore, in such a case, only an OpenSSL 3.0 server would be impacted when talking to a non-OpenSSL 3.0 client. If both endpoints are OpenSSL 3.0 then the attacker could modify data being sent in both directions. In this case both clients and servers could be affected, regardless of the application protocol. Note that in the absence of an attacker this bug means that an OpenSSL 3.0 endpoint communicating with a non-OpenSSL 3.0 endpoint will fail to complete the handshake when using this ciphersuite. The confidentiality of data is not impacted by this issue, i.e. an attacker cannot decrypt data that has been encrypted using this ciphersuite - they can only modify it. In order for this attack to work both endpoints must legitimately negotiate the RC4-MD5 ciphersuite. This ciphersuite is not compiled by default in OpenSSL 3.0, and is not available within the default provider or the default ciphersuite list. This ciphersuite will never be used if TLSv1.3 has been negotiated. In order for an OpenSSL 3.0 endpoint to use this ciphersuite the following must have occurred: 1) OpenSSL must have been compiled with the (non-default) compile time option enable-weak-ssl-ciphers 2) OpenSSL must have had the legacy provider explicitly loaded (either through application code or via configuration) 3) The ciphersuite must have been explicitly added to the ciphersuite list 4) The libssl security level must have been set to 0 (default is 1) 5) A version of SSL/TLS below TLSv1.3 must have been negotiated 6) Both endpoints must negotiate the RC4-MD5 ciphersuite in preference to any others that both endpoints have in common Fixed in OpenSSL 3.0.3 (Affected 3.0.0,3.0.1,3.0.2).

Weakness: CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2022-1434?

3 open source packages ship an affected version, including openssl-src. It affects 26 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.6 |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.6 |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.6 |

Products: Netapp A250 Firmware, Netapp A700s Firmware, Netapp Active Iq Unified Manager, Netapp Aff 500f Firmware, Netapp Aff 8300 Firmware, Netapp Aff 8700 Firmware, Netapp Aff A400 Firmware, Netapp Clustered Data Ontap, Netapp Clustered Data Ontap Antivirus Connector, Netapp Fabric-Attached Storage A400 Firmware, Netapp Fas 500f Firmware, Netapp Fas 8300 Firmware, Netapp Fas 8700 Firmware, Netapp H300e Firmware, Netapp H300s Firmware, Netapp H410s Firmware, Netapp H500e Firmware, Netapp H500s Firmware, Netapp H700e Firmware, Netapp H700s Firmware and 6 more.

## How do I fix CVE-2022-1434?

Upgrade openssl-src to 300.0.6 or later.

## Is CVE-2022-1434 being exploited?

There is no known exploitation of CVE-2022-1434 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-1473](https://insights.sbomify.com/CVE-2022-1473/): Resource leakage when decoding certificates and keys (high 7.5)
- [CVE-2022-1343](https://insights.sbomify.com/CVE-2022-1343/): OCSP_basic_verify may incorrectly verify the response signing certificate (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1434 and fix it if it is affected.

What it is: CVE-2022-1434 is a medium-severity vulnerability in Netapp Active Iq Unified Manager, published on 3 May 2022. 
Exploitation: There is no known exploitation of CVE-2022-1434 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.6
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.6
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1434/ (Markdown: https://insights.sbomify.com/CVE-2022-1434/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1434
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1434
- OSV: https://osv.dev/vulnerability/CVE-2022-1434

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1434/
Summaries are generated and may contain mistakes; the official description above is the record.
