{"answers":{"affected":"2 open source packages ship an affected version, including git-interface. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-1440 in the wild and no public exploit code.","fix":"Upgrade git-interface to 2.1.2 or later.","what":"CVE-2022-1440 is a critical command injection vulnerability in yarkeev/git-interface, published on 22 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-1440 and fix it if it is affected.\n\nWhat it is: CVE-2022-1440 is a critical command injection vulnerability in yarkeev/git-interface, published on 22 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-1440 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- git-interface (npm): affected all versions; fixed in 2.1.2\n- git-interface (npm): affected all versions; fixed in 2.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-1440/ (Markdown: https://insights.sbomify.com/CVE-2022-1440/index.md)","id":"CVE-2022-1440","markdown":"https://insights.sbomify.com/CVE-2022-1440/index.md","name":"CVE-2022-1440","record":{"aliases":["GHSA-qffw-8wg7-h665"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js git library","requires_auth":"none","summary":"An attacker can execute arbitrary OS commands via the --upload-pack argument in git clone operations within the git-interface library.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"git-interface","vendor":"git-interface_project"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Command Injection vulnerability in git-interface@2.1.1 in GitHub repository yarkeev/git-interface prior to 2.1.2. If both are provided by user input, then the use of a `--upload-pack` command-line argument feature of git is also supported for `git clone`, which would then allow for any operating system command to be spawned by the attacker.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection vulnerability in git-interface@2.1.1 in yarkeev/git-interface","id":"CVE-2022-1440","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Memory corruption in gpac","id":"CVE-2022-1441"},"packages":[{"ecosystem":"npm","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"git-interface","purl":null,"source":"GHSA-qffw-8wg7-h665"},{"ecosystem":"npm","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"git-interface","purl":"pkg:npm/git-interface","source":"GHSA-qffw-8wg7-h665"}],"prev":{"headline":"Reflected XSS on demo.microweber.org/demo/module/ in microweber/microweber","id":"CVE-2022-1439"},"products":["yarkeev/git-interface"],"published":"2022-04-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["yarkeev"]},"summary":"An attacker can execute arbitrary OS commands via the --upload-pack argument in git clone operations within the git-interface library.","url":"https://insights.sbomify.com/CVE-2022-1440/"}