# CVE-2022-1440: Command Injection vulnerability in git-interface@2.1.1 in yarkeev/git-interface

> An attacker can execute arbitrary OS commands via the --upload-pack argument in git clone operations within the git-interface library.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-qffw-8wg7-h665

## What is CVE-2022-1440?

CVE-2022-1440 is a critical command injection vulnerability in yarkeev/git-interface, published on 22 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Command Injection vulnerability in git-interface@2.1.1 in GitHub repository yarkeev/git-interface prior to 2.1.2. If both are provided by user input, then the use of a `--upload-pack` command-line argument feature of git is also supported for `git clone`, which would then allow for any operating system command to be spawned by the attacker.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-1440?

2 open source packages ship an affected version, including git-interface. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `git-interface` | npm | All versions | 2.1.2 |
| `git-interface` | npm | All versions | 2.1.2 |

Products: Git-Interface Project Git-Interface.

## How do I fix CVE-2022-1440?

Upgrade git-interface to 2.1.2 or later.

## Is CVE-2022-1440 being exploited?

There is no known exploitation of CVE-2022-1440 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1440 and fix it if it is affected.

What it is: CVE-2022-1440 is a critical command injection vulnerability in yarkeev/git-interface, published on 22 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-1440 in the wild and no public exploit code.

Affected packages and fixed versions:
- git-interface (npm): affected all versions; fixed in 2.1.2
- git-interface (npm): affected all versions; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1440/ (Markdown: https://insights.sbomify.com/CVE-2022-1440/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1440
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1440
- OSV: https://osv.dev/vulnerability/CVE-2022-1440

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1440/
Summaries are generated and may contain mistakes; the official description above is the record.
