CVE-2022-1460 Missing authorization in GitLab

Medium 6.1 Published Updated

GitLab failed to properly authorize scheduled pipelines, allowing a malicious user to execute pipelines with another user's permissions.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-1460?

CVE-2022-1460 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 11 May 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab affecting all versions starting from 9.2 before 14.8.6, all versions starting from 14.9 before 14.9.4, all versions starting from 14.10 before 14.10.1. GitLab was not performing correct authorizations on scheduled pipelines allowing a malicious user to run a pipeline in the context of another user.

Weakness: CWE-863

Which versions are affected by CVE-2022-1460?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 9.2.014.8.6, 14.9.4, 14.10.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-1460?

Upgrade gitlab to a fixed version for your release line: 14.8.6, 14.9.4 or 14.10.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2022-1460 being exploited?

There is no known exploitation of CVE-2022-1460 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-1460, GHSA-q7pq-xhw5-p4xw.

Is CVE-2022-1460 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free