CVE-2022-1473 Resource leakage when decoding certificates and keys

High 7.5 Published Updated

A memory leak in OpenSSL's hash table flushing during certificate decoding can cause unbounded memory growth, leading to denial of service in long-lived processes.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-1473?

CVE-2022-1473 is a high-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 3 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The OPENSSL_LH_flush() function, which empties a hash table, contains a bug that breaks reuse of the memory occuppied by the removed hash table entries. This function is used when decoding certificates or keys. If a long lived process periodically decodes certificates or keys its memory usage will expand without bounds and the process might be terminated by the operating system causing a denial of service. Also traversing the empty hash table entries will take increasingly more time. Typically such long lived processes might be TLS clients or TLS servers configured to accept client certificate authentication. The function was added in the OpenSSL 3.0 version thus older releases are not affected by the issue. Fixed in OpenSSL 3.0.3 (Affected 3.0.0,3.0.1,3.0.2).

Weakness: CWE-459

Which versions are affected by CVE-2022-1473?

3 open source packages ship an affected version, including openssl-src. It affects 26 products.

PackageAffectedFixed in
openssl-src crates.ioFrom 300.0.0300.0.6
openssl-src crates.ioFrom 300.0.0300.0.6
openssl-src crates.ioFrom 300.0.0300.0.6

Products include Netapp A250 Firmware, Netapp A700s Firmware, Netapp Active Iq Unified Manager, Netapp Aff 500f Firmware, Netapp Aff 8300 Firmware, Netapp Aff 8700 Firmware and 20 more.

How do I fix CVE-2022-1473?

Upgrade openssl-src to 300.0.6 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-1473 being exploited?

There is no known exploitation of CVE-2022-1473 in the wild and no public exploit code.

All Netapp Active Iq Unified Manager vulnerabilities

Sources

Also known as ALPINE-CVE-2022-1473, CLEANSTART-2026-KW51921, GHSA-g323-fr93-4j3c, RUSTSEC-2022-0025, UBUNTU-CVE-2022-1473.

Is CVE-2022-1473 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free