# CVE-2022-1473: Resource leakage when decoding certificates and keys

> A memory leak in OpenSSL's hash table flushing during certificate decoding can cause unbounded memory growth, leading to denial of service in long-lived processes.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 May 2022
- **Updated:** 14 Oct 2026
- **Also known as:** ALPINE-CVE-2022-1473, CLEANSTART-2026-KW51921, GHSA-g323-fr93-4j3c, RUSTSEC-2022-0025, UBUNTU-CVE-2022-1473

## What is CVE-2022-1473?

CVE-2022-1473 is a high-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 3 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The OPENSSL_LH_flush() function, which empties a hash table, contains a bug that breaks reuse of the memory occuppied by the removed hash table entries. This function is used when decoding certificates or keys. If a long lived process periodically decodes certificates or keys its memory usage will expand without bounds and the process might be terminated by the operating system causing a denial of service. Also traversing the empty hash table entries will take increasingly more time. Typically such long lived processes might be TLS clients or TLS servers configured to accept client certificate authentication. The function was added in the OpenSSL 3.0 version thus older releases are not affected by the issue. Fixed in OpenSSL 3.0.3 (Affected 3.0.0,3.0.1,3.0.2).

Weakness: CWE-459 (Incomplete Cleanup)

## Which versions are affected by CVE-2022-1473?

3 open source packages ship an affected version, including openssl-src. It affects 26 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.6 |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.6 |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.6 |

Products: Netapp A250 Firmware, Netapp A700s Firmware, Netapp Active Iq Unified Manager, Netapp Aff 500f Firmware, Netapp Aff 8300 Firmware, Netapp Aff 8700 Firmware, Netapp Aff A400 Firmware, Netapp Clustered Data Ontap, Netapp Clustered Data Ontap Antivirus Connector, Netapp Fabric-Attached Storage A400 Firmware, Netapp Fas 500f Firmware, Netapp Fas 8300 Firmware, Netapp Fas 8700 Firmware, Netapp H300e Firmware, Netapp H300s Firmware, Netapp H410s Firmware, Netapp H500e Firmware, Netapp H500s Firmware, Netapp H700e Firmware, Netapp H700s Firmware and 6 more.

## How do I fix CVE-2022-1473?

Upgrade openssl-src to 300.0.6 or later.

## Is CVE-2022-1473 being exploited?

There is no known exploitation of CVE-2022-1473 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-1434](https://insights.sbomify.com/CVE-2022-1434/): Incorrect MAC key used in the RC4-MD5 ciphersuite (medium 5.9)
- [CVE-2022-1343](https://insights.sbomify.com/CVE-2022-1343/): OCSP_basic_verify may incorrectly verify the response signing certificate (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1473 and fix it if it is affected.

What it is: CVE-2022-1473 is a high-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 3 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-1473 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.6
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.6
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1473/ (Markdown: https://insights.sbomify.com/CVE-2022-1473/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1473
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1473
- OSV: https://osv.dev/vulnerability/CVE-2022-1473

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1473/
Summaries are generated and may contain mistakes; the official description above is the record.
