# CVE-2022-1514: Stored XSS via upload plugin functionality in zip format in neorazorx/facturascripts

> Attackers can inject malicious scripts via zip plugin uploads, leading to data exfiltration or account takeover in FacturaScripts.

- **Severity:** Critical 9.0 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-p3w3-4ppm-c3f6

## What is CVE-2022-1514?

CVE-2022-1514 is a critical cross-site scripting vulnerability in neorazorx/facturascripts, published on 28 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Stored XSS via upload plugin functionality in zip format in GitHub repository neorazorx/facturascripts prior to 2022.06. Cross-site scripting attacks can have devastating consequences. Code injected into a vulnerable application can exfiltrate data or install malware on the user's machine. Attackers can masquerade as authorized users via session cookies, allowing them to perform any action allowed by the user account.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-1514?

2 open source packages ship an affected version, including facturascripts/facturascripts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `facturascripts/facturascripts` | Packagist | All versions | 2022.06 |
| `facturascripts/facturascripts` | Packagist | All versions | 2022.06 |

Products: Facturascripts Facturascripts.

## How do I fix CVE-2022-1514?

Upgrade facturascripts/facturascripts to 2022.06 or later.

## Is CVE-2022-1514 being exploited?

There is no known exploitation of CVE-2022-1514 in the wild and no public exploit code.

## Other vulnerabilities in neorazorx/facturascripts

- [CVE-2022-1571](https://insights.sbomify.com/CVE-2022-1571/): Cross-site scripting - Reflected in Create Subaccount in neorazorx/facturascripts (critical 9.9)
- [CVE-2022-1715](https://insights.sbomify.com/CVE-2022-1715/): Account Takeover in neorazorx/facturascripts (critical 9.8)
- [CVE-2022-1682](https://insights.sbomify.com/CVE-2022-1682/): Reflected Xss using url based payload in neorazorx/facturascripts (critical 9.4)
- [CVE-2022-1457](https://insights.sbomify.com/CVE-2022-1457/): Store XSS in title parameter executing at EditUser Page & EditProducto page in neorazorx/facturascripts (critical 9.0)
- [CVE-2026-25514](https://insights.sbomify.com/CVE-2026-25514/): FacturaScripts has SQL Injection vulnerability in Autocomplete Actions (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1514 and fix it if it is affected.

What it is: CVE-2022-1514 is a critical cross-site scripting vulnerability in neorazorx/facturascripts, published on 28 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-1514 in the wild and no public exploit code.

Affected packages and fixed versions:
- facturascripts/facturascripts (Packagist): affected all versions; fixed in 2022.06
- facturascripts/facturascripts (Packagist): affected all versions; fixed in 2022.06

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1514/ (Markdown: https://insights.sbomify.com/CVE-2022-1514/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1514
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1514
- OSV: https://osv.dev/vulnerability/CVE-2022-1514

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1514/
Summaries are generated and may contain mistakes; the official description above is the record.
