# CVE-2022-1537: Race Condition in Grunt

> A TOCTOU race condition in GruntJS file.copy allows local attackers to perform arbitrary file writes, potentially leading to privilege escalation.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-44082, DEBIAN-CVE-2022-1537, DLA-3383-1, GHSA-rm36-94g8-835r, UBUNTU-CVE-2022-1537

## What is CVE-2022-1537?

CVE-2022-1537 is a high-severity vulnerability in gruntjs/grunt, published on 10 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

file.copy operations in GruntJS are vulnerable to a TOCTOU race condition leading to arbitrary file write in GitHub repository gruntjs/grunt prior to 1.5.3. This vulnerability is capable of arbitrary file writes which can lead to local privilege escalation to the GruntJS user if a lower-privileged user has write access to both source and destination directories as the lower-privileged user can create a symlink to the GruntJS user's .bashrc file or replace /etc/shadow file if the GruntJS user is root.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2022-1537?

2 open source packages ship an affected version, including grunt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grunt` | npm | All versions | 1.5.3 |
| `grunt` | npm | All versions | 1.5.3 |

Products: Gruntjs Grunt.

## How do I fix CVE-2022-1537?

Upgrade grunt to 1.5.3 or later.

## Is CVE-2022-1537 being exploited?

There is no known exploitation of CVE-2022-1537 in the wild and no public exploit code.

## Other vulnerabilities in gruntjs/grunt

- [CVE-2022-0436](https://insights.sbomify.com/CVE-2022-0436/): Path Traversal in gruntjs/grunt (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1537 and fix it if it is affected.

What it is: CVE-2022-1537 is a high-severity vulnerability in gruntjs/grunt, published on 10 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-1537 in the wild and no public exploit code.

Affected packages and fixed versions:
- grunt (npm): affected all versions; fixed in 1.5.3
- grunt (npm): affected all versions; fixed in 1.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1537/ (Markdown: https://insights.sbomify.com/CVE-2022-1537/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1537
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1537
- OSV: https://osv.dev/vulnerability/CVE-2022-1537

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1537/
Summaries are generated and may contain mistakes; the official description above is the record.
