{"answers":{"affected":"2 open source packages ship an affected version, including luyadev/yii-helpers. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-1544 in the wild and no public exploit code.","fix":"Upgrade luyadev/yii-helpers to 1.2.1 or later.","what":"CVE-2022-1544 is a high-severity code injection vulnerability in luyadev/yii-helpers, published on 1 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-1544 and fix it if it is affected.\n\nWhat it is: CVE-2022-1544 is a high-severity code injection vulnerability in luyadev/yii-helpers, published on 1 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-1544 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- luyadev/yii-helpers (Packagist): affected all versions; fixed in 1.2.1\n- luyadev/yii-helpers (Packagist): affected all versions; fixed in 1.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-1544/ (Markdown: https://insights.sbomify.com/CVE-2022-1544/index.md)","id":"CVE-2022-1544","markdown":"https://insights.sbomify.com/CVE-2022-1544/index.md","name":"CVE-2022-1544","record":{"aliases":["GHSA-f9p3-h6cg-2cjr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP helper library","requires_auth":"low_privilege","summary":"Attackers can inject malicious formulas into CSV files to execute code or exfiltrate data via client-side injection in the luyadev/yii-helpers library.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"yii-helpers","vendor":"luya"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-1236","name":"Improper Neutralization of Formula Elements in a CSV File"}],"description":"Formula Injection/CSV Injection due to Improper Neutralization of Formula Elements in CSV File in GitHub repository luyadev/yii-helpers prior to 1.2.1. Successful exploitation can lead to impacts such as client-sided command injection, code execution, or remote ex-filtration of contained confidential data.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Formula Injection/CSV Injection due to Improper Neutralization of Formula Elements in CSV File in luyadev/yii-helpers","id":"CVE-2022-1544","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Information disclosure in GitLab","id":"CVE-2022-1545"},"packages":[{"ecosystem":"Packagist","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"luyadev/yii-helpers","purl":null,"source":"GHSA-f9p3-h6cg-2cjr"},{"ecosystem":"Packagist","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"luyadev/yii-helpers","purl":"pkg:composer/luyadev/yii-helpers","source":"GHSA-f9p3-h6cg-2cjr"}],"prev":{"headline":"Improper handling of Length parameter in erudika/scoold","id":"CVE-2022-1543"},"products":["luyadev/yii-helpers"],"published":"2022-05-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["luyadev"]},"summary":"Attackers can inject malicious formulas into CSV files to execute code or exfiltrate data via client-side injection in the luyadev/yii-helpers library.","url":"https://insights.sbomify.com/CVE-2022-1544/"}