# CVE-2022-1544: Formula Injection/CSV Injection due to Improper Neutralization of Formula Elements in CSV File in luyadev/yii-helpers

> Attackers can inject malicious formulas into CSV files to execute code or exfiltrate data via client-side injection in the luyadev/yii-helpers library.

- **Severity:** High 8.0 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-f9p3-h6cg-2cjr

## What is CVE-2022-1544?

CVE-2022-1544 is a high-severity code injection vulnerability in luyadev/yii-helpers, published on 1 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Formula Injection/CSV Injection due to Improper Neutralization of Formula Elements in CSV File in GitHub repository luyadev/yii-helpers prior to 1.2.1. Successful exploitation can lead to impacts such as client-sided command injection, code execution, or remote ex-filtration of contained confidential data.

Weakness: CWE-1236 (Improper Neutralization of Formula Elements in a CSV File)

## Which versions are affected by CVE-2022-1544?

2 open source packages ship an affected version, including luyadev/yii-helpers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `luyadev/yii-helpers` | Packagist | All versions | 1.2.1 |
| `luyadev/yii-helpers` | Packagist | All versions | 1.2.1 |

Products: Luya Yii-Helpers.

## How do I fix CVE-2022-1544?

Upgrade luyadev/yii-helpers to 1.2.1 or later.

## Is CVE-2022-1544 being exploited?

There is no known exploitation of CVE-2022-1544 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1544 and fix it if it is affected.

What it is: CVE-2022-1544 is a high-severity code injection vulnerability in luyadev/yii-helpers, published on 1 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-1544 in the wild and no public exploit code.

Affected packages and fixed versions:
- luyadev/yii-helpers (Packagist): affected all versions; fixed in 1.2.1
- luyadev/yii-helpers (Packagist): affected all versions; fixed in 1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1544/ (Markdown: https://insights.sbomify.com/CVE-2022-1544/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1544
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1544
- OSV: https://osv.dev/vulnerability/CVE-2022-1544

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1544/
Summaries are generated and may contain mistakes; the official description above is the record.
