# CVE-2022-1554: Path Traversal due to `send_file` call in clinical-genomics/scout

> An attacker can read arbitrary files from the server via a path traversal vulnerability in the file sending functionality of the Scout clinical genomics application.

- **Severity:** Medium 6.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-694v-63fq-fmr4, PYSEC-2026-749

## What is CVE-2022-1554?

CVE-2022-1554 is a medium-severity path traversal vulnerability in clinical-genomics/scout, published on 3 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Path Traversal due to `send_file` call in GitHub repository clinical-genomics/scout prior to 4.52.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-36 (Absolute Path Traversal)

## Which versions are affected by CVE-2022-1554?

3 open source packages ship an affected version, including scout-browser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `scout-browser` | PyPI | All versions | 4.52 |
| `scout-browser` | PyPI | All versions | 4.52 |
| `scout-browser` | PyPI | All versions | 4.52 |

Products: Clinical-Genomics Scout.

## How do I fix CVE-2022-1554?

Upgrade scout-browser to 4.52 or later.

## Is CVE-2022-1554 being exploited?

There is no known exploitation of CVE-2022-1554 in the wild and no public exploit code.

## Other vulnerabilities in clinical-genomics/scout

- [CVE-2022-1592](https://insights.sbomify.com/CVE-2022-1592/): Server-Side Request Forgery in scout in clinical-genomics/scout (critical 9.4)
- [CVE-2024-47530](https://insights.sbomify.com/CVE-2024-47530/): Scout contains an Open Redirect on Login via `next` (medium 5.4)
- [CVE-2024-47531](https://insights.sbomify.com/CVE-2024-47531/): Scout contains insufficient output escaping of attachment names (medium 4.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1554 and fix it if it is affected.

What it is: CVE-2022-1554 is a medium-severity path traversal vulnerability in clinical-genomics/scout, published on 3 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-1554 in the wild and no public exploit code.

Affected packages and fixed versions:
- scout-browser (PyPI): affected all versions; fixed in 4.52
- scout-browser (PyPI): affected all versions; fixed in 4.52
- scout-browser (PyPI): affected all versions; fixed in 4.52

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1554/ (Markdown: https://insights.sbomify.com/CVE-2022-1554/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1554
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1554
- OSV: https://osv.dev/vulnerability/CVE-2022-1554

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1554/
Summaries are generated and may contain mistakes; the official description above is the record.
