# CVE-2022-1572: HTML2WP <= 1.0.0 - Subscriber+ Arbitrary File Deletion

> Authenticated subscribers can delete arbitrary files due to missing authorization and CSRF checks in an AJAX action.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-c938-72w7-26mv

## What is CVE-2022-1572?

CVE-2022-1572 is a high-severity missing authorization vulnerability in Unknown HTML2WP, published on 27 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The HTML2WP WordPress plugin through 1.0.0 does not have authorisation and CSRF checks in an AJAX action, available to any authenticated users such as subscriber, which could allow them to delete arbitrary file

Weakness: CWE-862 (Missing Authorization), CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2022-1572?

It affects 1 product.


Products: Html2wp Project Html2wp.

## How do I fix CVE-2022-1572?

No fix has been published for CVE-2022-1572 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-1572 being exploited?

There is no known exploitation of CVE-2022-1572 in the wild and no public exploit code.

## Other vulnerabilities in Unknown HTML2WP

- [CVE-2022-1574](https://insights.sbomify.com/CVE-2022-1574/): HTML2WP <= 1.0.0 - Unauthenticated Arbitrary File Upload (critical 9.8)
- [CVE-2022-1573](https://insights.sbomify.com/CVE-2022-1573/): HTML2WP <= 1.0.0 - Arbitrary Settings Update via CSRF (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1572 and fix it if it is affected.

What it is: CVE-2022-1572 is a high-severity missing authorization vulnerability in Unknown HTML2WP, published on 27 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-1572 in the wild and no public exploit code.

Affected product: Unknown HTML2WP. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1572/ (Markdown: https://insights.sbomify.com/CVE-2022-1572/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1572
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1572
- OSV: https://osv.dev/vulnerability/CVE-2022-1572

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1572/
Summaries are generated and may contain mistakes; the official description above is the record.
