# CVE-2022-1631: Users Account Pre-Takeover or Users Account Takeover. in microweber/microweber

> Attackers can hijack user accounts by registering with victim emails due to missing email confirmation and social login validation flaws.

- **Severity:** Medium 6.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-73rp-q4rx-5grc

## What is CVE-2022-1631?

CVE-2022-1631 is a medium-severity authentication bypass vulnerability in Microweber Microweber, published on 9 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Users Account Pre-Takeover or Users Account Takeover. in GitHub repository microweber/microweber prior to 1.2.15. Victim Account Take Over. Since, there is no email confirmation, an attacker can easily create an account in the application using the Victim’s Email. This allows an attacker to gain pre-authentication to the victim’s account. Further, due to the lack of proper validation of email coming from Social Login and failing to check if an account already exists, the victim will not identify if an account is already existing. Hence, the attacker’s persistence will remain. An attacker would be able to see all the activities performed by the victim user impacting the confidentiality and attempt to modify/corrupt the data impacting the integrity and availability factor. This attack becomes more interesting when an attacker can register an account from an employee’s email address. Assuming the organization uses G-Suite, it is much more impactful to hijack into an employee’s account.

Weakness: CWE-863 (Incorrect Authorization), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2022-1631?

2 open source packages ship an affected version, including microweber/microweber. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `microweber/microweber` | Packagist | All versions | 1.2.15 |
| `microweber/microweber` | Packagist | All versions | 1.2.15 |

Products: Microweber Microweber.

## How do I fix CVE-2022-1631?

Upgrade microweber/microweber to 1.2.15 or later.

## Is CVE-2022-1631 being exploited?

There is no known exploitation of CVE-2022-1631 in the wild and no public exploit code.

Public exploit code:

- Microweber CMS 1.2.15 - Account Takeover (exploitdb)

## Other vulnerabilities in Microweber Microweber

- [CVE-2022-0558](https://insights.sbomify.com/CVE-2022-0558/): Cross-site Scripting (XSS) - Stored in microweber/microweber (critical 9.8)
- [CVE-2020-23138](https://insights.sbomify.com/CVE-2020-23138/): File upload in n/a (critical 9.8)
- [CVE-2022-0688](https://insights.sbomify.com/CVE-2022-0688/): Business Logic Errors in microweber/microweber (critical 9.4)
- [CVE-2022-0660](https://insights.sbomify.com/CVE-2022-0660/): Generation of Error Message Containing Sensitive Information in microweber/microweber (critical 9.4)
- [CVE-2022-0913](https://insights.sbomify.com/CVE-2022-0913/): Integer Overflow or Wraparound in microweber/microweber (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1631 and fix it if it is affected.

What it is: CVE-2022-1631 is a medium-severity authentication bypass vulnerability in Microweber Microweber, published on 9 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-1631 in the wild and no public exploit code.

Affected packages and fixed versions:
- microweber/microweber (Packagist): affected all versions; fixed in 1.2.15
- microweber/microweber (Packagist): affected all versions; fixed in 1.2.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1631/ (Markdown: https://insights.sbomify.com/CVE-2022-1631/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1631
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1631
- OSV: https://osv.dev/vulnerability/CVE-2022-1631

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1631/
Summaries are generated and may contain mistakes; the official description above is the record.
