CVE-2022-1680 Business logic in GitLab

Critical 9.9 Published Updated

A Premium group owner can take over arbitrary user accounts by modifying their email addresses via SCIM when SAML SSO is enabled.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-1680?

CVE-2022-1680 is a critical vulnerability in Gitlab Gitlab, published on 6 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An account takeover issue has been discovered in GitLab EE affecting all versions starting from 11.10 before 14.9.5, all versions starting from 14.10 before 14.10.4, all versions starting from 15.0 before 15.0.1. When group SAML SSO is configured, the SCIM feature (available only on Premium+ subscriptions) may allow any owner of a Premium group to invite arbitrary users through their username and email, then change those users' email addresses via SCIM to an attacker controlled email address and thus - in the absence of 2FA - take over those accounts. It is also possible for the attacker to change the display name and username of the targeted account.

Which versions are affected by CVE-2022-1680?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.0.014.9.5, 14.10.4, 15.0.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-1680?

Upgrade gitlab to a fixed version for your release line: 14.9.5, 14.10.4 or 15.0.1.

Is CVE-2022-1680 being exploited?

There is no known exploitation of CVE-2022-1680 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-1680, GHSA-whxf-7mv4-g5wm.

Is CVE-2022-1680 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free