{"answers":{"affected":"2 open source packages ship an affected version, including bootstrap-table. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-1726 in the wild and no public exploit code.","fix":"Upgrade bootstrap-table to 1.20.2 or later.","what":"CVE-2022-1726 is a medium-severity cross-site scripting vulnerability in wenzhixin/bootstrap-table, published on 16 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-1726 and fix it if it is affected.\n\nWhat it is: CVE-2022-1726 is a medium-severity cross-site scripting vulnerability in wenzhixin/bootstrap-table, published on 16 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-1726 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bootstrap-table (npm): affected all versions; fixed in 1.20.2\n- bootstrap-table (npm): affected all versions; fixed in 1.20.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-1726/ (Markdown: https://insights.sbomify.com/CVE-2022-1726/index.md)","id":"CVE-2022-1726","markdown":"https://insights.sbomify.com/CVE-2022-1726/index.md","name":"CVE-2022-1726","record":{"aliases":["DEBIAN-CVE-2022-1726","GHSA-grw5-g9h2-wpg8","UBUNTU-CVE-2022-1726"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"JavaScript table library","requires_auth":"low_privilege","summary":"Cross-site scripting in Bootstrap Table allows attackers to steal session cookies and data when the HTML content export option is enabled.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"bootstrap_table","vendor":"bootstrap-table"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:L","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Bootstrap Tables XSS vulnerability with Table Export plug-in when exportOptions: htmlContent is true in GitHub repository wenzhixin/bootstrap-table prior to 1.20.2. Disclosing session cookies, disclosing secure session data, exfiltrating data to third-parties.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in bootstrap-table","id":"CVE-2022-1726","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Improper Input Validation in jgraph/drawio","id":"CVE-2022-1727"},"packages":[{"ecosystem":"npm","fixed":["1.20.2"],"introduced":["0"],"last_affected":[],"package":"bootstrap-table","purl":null,"source":"GHSA-grw5-g9h2-wpg8"},{"ecosystem":"npm","fixed":["1.20.2"],"introduced":["0"],"last_affected":[],"package":"bootstrap-table","purl":"pkg:npm/bootstrap-table","source":"GHSA-grw5-g9h2-wpg8"}],"prev":{"headline":"NULL Pointer Dereference in vim/vim","id":"CVE-2022-1725"},"products":["wenzhixin/bootstrap-table"],"published":"2022-05-16","related":[{"cvss_score":3.1,"headline":"Cross-site Scripting (XSS)","id":"CVE-2021-23472","kev_date_added":null,"published":"2021-11-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["wenzhixin"]},"summary":"Cross-site scripting in Bootstrap Table allows attackers to steal session cookies and data when the HTML content export option is enabled.","url":"https://insights.sbomify.com/CVE-2022-1726/"}