# CVE-2022-1726: Cross-site Scripting in bootstrap-table

> Cross-site scripting in Bootstrap Table allows attackers to steal session cookies and data when the HTML content export option is enabled.

- **Severity:** Medium 6.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-1726, GHSA-grw5-g9h2-wpg8, UBUNTU-CVE-2022-1726

## What is CVE-2022-1726?

CVE-2022-1726 is a medium-severity cross-site scripting vulnerability in wenzhixin/bootstrap-table, published on 16 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Bootstrap Tables XSS vulnerability with Table Export plug-in when exportOptions: htmlContent is true in GitHub repository wenzhixin/bootstrap-table prior to 1.20.2. Disclosing session cookies, disclosing secure session data, exfiltrating data to third-parties.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-1726?

2 open source packages ship an affected version, including bootstrap-table. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bootstrap-table` | npm | All versions | 1.20.2 |
| `bootstrap-table` | npm | All versions | 1.20.2 |

Products: Bootstrap-Table Bootstrap Table.

## How do I fix CVE-2022-1726?

Upgrade bootstrap-table to 1.20.2 or later.

## Is CVE-2022-1726 being exploited?

There is no known exploitation of CVE-2022-1726 in the wild and no public exploit code.

## Other vulnerabilities in wenzhixin/bootstrap-table

- [CVE-2021-23472](https://insights.sbomify.com/CVE-2021-23472/): Cross-site Scripting (XSS) (low 3.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1726 and fix it if it is affected.

What it is: CVE-2022-1726 is a medium-severity cross-site scripting vulnerability in wenzhixin/bootstrap-table, published on 16 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-1726 in the wild and no public exploit code.

Affected packages and fixed versions:
- bootstrap-table (npm): affected all versions; fixed in 1.20.2
- bootstrap-table (npm): affected all versions; fixed in 1.20.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1726/ (Markdown: https://insights.sbomify.com/CVE-2022-1726/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1726
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1726
- OSV: https://osv.dev/vulnerability/CVE-2022-1726

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1726/
Summaries are generated and may contain mistakes; the official description above is the record.
