CVE-2022-1783 Missing authorization in GitLab

Low 2.7 Published Updated

Malicious group maintainers can bypass restrictions to add members to projects via the REST API, potentially escalating privileges or modifying project access.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-1783?

CVE-2022-1783 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 6 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 14.3 before 14.9.5, all versions starting from 14.10 before 14.10.4, all versions starting from 15.0 before 15.0.1. It may be possible for malicious group maintainers to add new members to a project within their group, through the REST API, even after their group owner enabled a setting to prevent members from being added to projects within that group.

Which versions are affected by CVE-2022-1783?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 14.3.014.9.5, 14.10.4, 15.0.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-1783?

Upgrade gitlab to a fixed version for your release line: 14.9.5, 14.10.4 or 15.0.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2022-1783 being exploited?

There is no known exploitation of CVE-2022-1783 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-1783, GHSA-gqc9-9f54-xc45.

Is CVE-2022-1783 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free