{"answers":{"affected":"3 open source packages ship an affected version, including publify_core and publify. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-1812 exists.","fix":"Upgrade publify_core to 9.2.10 or later.","what":"CVE-2022-1812 is a high-severity vulnerability in publify/publify, published on 14 Jan 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-1812 and fix it if it is affected.\n\nWhat it is: CVE-2022-1812 is a high-severity vulnerability in publify/publify, published on 14 Jan 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-1812 exists.\n\nAffected packages and fixed versions:\n- publify_core (RubyGems): affected all versions; fixed in 9.2.10\n- publify_core (RubyGems): affected all versions; fixed in 9.2.10\n- publify (Bitnami): affected all versions; fixed in 9.2.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-1812/ (Markdown: https://insights.sbomify.com/CVE-2022-1812/index.md)","id":"CVE-2022-1812","markdown":"https://insights.sbomify.com/CVE-2022-1812/index.md","name":"CVE-2022-1812","record":{"aliases":["BIT-publify-2022-1812","GHSA-rc42-jghf-vr8f"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Publify blog platform","requires_auth":"high_privilege","summary":"An integer overflow in Publify allows attackers to cause a denial of service, requiring an upgrade to the latest version.","user_interaction":"required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"publify","vendor":"publify_project"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Integer Overflow or Wraparound in GitHub repository publify/publify prior to 9.2.10.","ecosystems":["Bitnami","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Integer Overflow or Wraparound in publify/publify","id":"CVE-2022-1812","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"integer_overflow","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"OS Command Injection in yogeshojha/rengine","id":"CVE-2022-1813"},"packages":[{"ecosystem":"Bitnami","fixed":["9.2.10"],"introduced":["0"],"last_affected":[],"package":"publify","purl":"pkg:bitnami/publify","source":"BIT-publify-2022-1812"},{"ecosystem":"RubyGems","fixed":["9.2.10"],"introduced":["0"],"last_affected":[],"package":"publify_core","purl":null,"source":"GHSA-rc42-jghf-vr8f"},{"ecosystem":"RubyGems","fixed":["9.2.10"],"introduced":["0"],"last_affected":[],"package":"publify_core","purl":"pkg:gem/publify_core","source":"GHSA-rc42-jghf-vr8f"}],"prev":{"headline":"Unrestricted Upload of File with Dangerous Type in publify/publify","id":"CVE-2022-1811"},"products":["publify/publify"],"published":"2023-01-14","related":[{"cvss_score":9.9,"headline":"Authorization Bypass Through User-Controlled Key in publify/publify","id":"CVE-2022-1810","kev_date_added":null,"published":"2022-05-23"},{"cvss_score":9.1,"headline":"Unrestricted Upload of File with Dangerous Type in publify/publify","id":"CVE-2022-1811","kev_date_added":null,"published":"2022-05-23"},{"cvss_score":8.8,"headline":"Leaking password protected articles content due to improper access control in publify/publify","id":"CVE-2022-1553","kev_date_added":null,"published":"2022-05-16"},{"cvss_score":8.4,"headline":"Improper Input Validation in publify/publify","id":"CVE-2023-0299","kev_date_added":null,"published":"2023-01-14"},{"cvss_score":8.1,"headline":"Weak Password Requirements in publify/publify","id":"CVE-2023-0569","kev_date_added":null,"published":"2023-01-29"},{"cvss_score":6.5,"headline":"Business Logic Errors in publify/publify","id":"CVE-2022-0524","kev_date_added":null,"published":"2022-02-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-07","vendors":["publify"]},"summary":"An integer overflow in Publify allows attackers to cause a denial of service, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2022-1812/"}