# CVE-2022-1812: Integer Overflow or Wraparound in publify/publify

> An integer overflow in Publify allows attackers to cause a denial of service, requiring an upgrade to the latest version.

- **Severity:** High 7.6 (`CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jan 2023
- **Updated:** 7 Apr 2025
- **Also known as:** BIT-publify-2022-1812, GHSA-rc42-jghf-vr8f

## What is CVE-2022-1812?

CVE-2022-1812 is a high-severity vulnerability in publify/publify, published on 14 Jan 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Integer Overflow or Wraparound in GitHub repository publify/publify prior to 9.2.10.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2022-1812?

3 open source packages ship an affected version, including publify_core and publify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `publify_core` | RubyGems | All versions | 9.2.10 |
| `publify_core` | RubyGems | All versions | 9.2.10 |
| `publify` | Bitnami | All versions | 9.2.10 |

Products: Publify Project Publify.

## How do I fix CVE-2022-1812?

Upgrade publify_core to 9.2.10 or later.

## Is CVE-2022-1812 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-1812 exists.

## Other vulnerabilities in publify/publify

- [CVE-2022-1810](https://insights.sbomify.com/CVE-2022-1810/): Authorization Bypass Through User-Controlled Key in publify/publify (critical 9.9)
- [CVE-2022-1811](https://insights.sbomify.com/CVE-2022-1811/): Unrestricted Upload of File with Dangerous Type in publify/publify (critical 9.1)
- [CVE-2022-1553](https://insights.sbomify.com/CVE-2022-1553/): Leaking password protected articles content due to improper access control in publify/publify (high 8.8)
- [CVE-2023-0299](https://insights.sbomify.com/CVE-2023-0299/): Improper Input Validation in publify/publify (high 8.4)
- [CVE-2023-0569](https://insights.sbomify.com/CVE-2023-0569/): Weak Password Requirements in publify/publify (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1812 and fix it if it is affected.

What it is: CVE-2022-1812 is a high-severity vulnerability in publify/publify, published on 14 Jan 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-1812 exists.

Affected packages and fixed versions:
- publify_core (RubyGems): affected all versions; fixed in 9.2.10
- publify_core (RubyGems): affected all versions; fixed in 9.2.10
- publify (Bitnami): affected all versions; fixed in 9.2.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1812/ (Markdown: https://insights.sbomify.com/CVE-2022-1812/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1812
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1812
- OSV: https://osv.dev/vulnerability/CVE-2022-1812

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1812/
Summaries are generated and may contain mistakes; the official description above is the record.
