# CVE-2022-1848: Business Logic Errors in erudika/para

> Attackers can exploit business logic errors in the Para backend server to bypass intended application workflows.

- **Severity:** Critical 9.0 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-4793-8wwh-jxxr

## What is CVE-2022-1848?

CVE-2022-1848 is a critical vulnerability in erudika/para, published on 24 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Business Logic Errors in GitHub repository erudika/para prior to 1.45.11.

Weakness: CWE-840

## Which versions are affected by CVE-2022-1848?

2 open source packages ship an affected version, including com.erudika:para-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.erudika:para-core` | Maven | All versions | 1.46.0 |
| `com.erudika:para-core` | Maven | All versions | 1.46.0 |

Products: Erudika Para.

## How do I fix CVE-2022-1848?

Upgrade com.erudika:para-core to 1.46.0 or later.

## Is CVE-2022-1848 being exploited?

There is no known exploitation of CVE-2022-1848 in the wild and no public exploit code.

## Other vulnerabilities in erudika/para

- [CVE-2022-1782](https://insights.sbomify.com/CVE-2022-1782/): Cross-site Scripting (XSS) - Generic in erudika/para (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1848 and fix it if it is affected.

What it is: CVE-2022-1848 is a critical vulnerability in erudika/para, published on 24 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-1848 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.erudika:para-core (Maven): affected all versions; fixed in 1.46.0
- com.erudika:para-core (Maven): affected all versions; fixed in 1.46.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1848/ (Markdown: https://insights.sbomify.com/CVE-2022-1848/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1848
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1848
- OSV: https://osv.dev/vulnerability/CVE-2022-1848

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1848/
Summaries are generated and may contain mistakes; the official description above is the record.
