# CVE-2022-1850: Path Traversal in filegator/filegator

> An attacker can exploit a path traversal vulnerability in Filegator to read or modify files outside the intended directory.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-rrhw-54r8-545q

## What is CVE-2022-1850?

CVE-2022-1850 is a medium-severity path traversal vulnerability in filegator/filegator, published on 24 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Path Traversal in GitHub repository filegator/filegator prior to 7.8.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-1850?

2 open source packages ship an affected version, including filegator/filegator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `filegator/filegator` | Packagist | All versions | 7.8.0 |
| `filegator/filegator` | Packagist | All versions | 7.8.0 |

Products: Filegator Filegator.

## How do I fix CVE-2022-1850?

Upgrade filegator/filegator to 7.8.0 or later.

## Is CVE-2022-1850 being exploited?

There is no known exploitation of CVE-2022-1850 in the wild and no public exploit code.

## Other vulnerabilities in filegator/filegator

- [CVE-2026-63358](https://insights.sbomify.com/CVE-2026-63358/): FileGator privilege escalation (high 8.4)
- [CVE-2022-1849](https://insights.sbomify.com/CVE-2022-1849/): Session Fixation in filegator/filegator (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1850 and fix it if it is affected.

What it is: CVE-2022-1850 is a medium-severity path traversal vulnerability in filegator/filegator, published on 24 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-1850 in the wild and no public exploit code.

Affected packages and fixed versions:
- filegator/filegator (Packagist): affected all versions; fixed in 7.8.0
- filegator/filegator (Packagist): affected all versions; fixed in 7.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1850/ (Markdown: https://insights.sbomify.com/CVE-2022-1850/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1850
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1850
- OSV: https://osv.dev/vulnerability/CVE-2022-1850

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1850/
Summaries are generated and may contain mistakes; the official description above is the record.
