{"answers":{"affected":"2 open source packages ship an affected version, including devcert. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-1929 in the wild and no public exploit code.","fix":"Upgrade devcert to 1.2.1 or later.","what":"CVE-2022-1929 is a medium-severity denial of service vulnerability in devcert, published on 1 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-1929 and fix it if it is affected.\n\nWhat it is: CVE-2022-1929 is a medium-severity denial of service vulnerability in devcert, published on 1 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-1929 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- devcert (npm): affected all versions; fixed in 1.2.1\n- devcert (npm): affected all versions; fixed in 1.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-1929/ (Markdown: https://insights.sbomify.com/CVE-2022-1929/index.md)","id":"CVE-2022-1929","markdown":"https://insights.sbomify.com/CVE-2022-1929/index.md","name":"CVE-2022-1929","record":{"aliases":["GHSA-fp36-299x-pwmw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js certificate library","requires_auth":"none","summary":"An attacker can cause a denial of service in the devcert library by supplying malicious input to the certificateFor method, triggering an exponential regular expression backtracking.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"JFROG","cpe":[{"product":"devcert","vendor":"devcert_project"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the devcert npm package, when an attacker is able to supply arbitrary input to the certificateFor method","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Exponential ReDoS in devcert","id":"CVE-2022-1929","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"ReDoS in eth-account encode_structured_data function","id":"CVE-2022-1930"},"packages":[{"ecosystem":"npm","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"devcert","purl":null,"source":"GHSA-fp36-299x-pwmw"},{"ecosystem":"npm","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"devcert","purl":"pkg:npm/devcert","source":"GHSA-fp36-299x-pwmw"}],"prev":{"headline":"Cross-site Scripting (XSS) - Stored in go-gitea/gitea","id":"CVE-2022-1928"},"products":["devcert"],"published":"2022-06-01","related":[{"cvss_score":9.8,"headline":"Injection and Command Injection in devcert","id":"CVE-2020-8186","kev_date_added":null,"published":"2020-07-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["devcert"]},"summary":"An attacker can cause a denial of service in the devcert library by supplying malicious input to the certificateFor method, triggering an exponential regular expression backtracking.","url":"https://insights.sbomify.com/CVE-2022-1929/"}