# CVE-2022-1929: Exponential ReDoS in devcert

> An attacker can cause a denial of service in the devcert library by supplying malicious input to the certificateFor method, triggering an exponential regular expression backtracking.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-fp36-299x-pwmw

## What is CVE-2022-1929?

CVE-2022-1929 is a medium-severity denial of service vulnerability in devcert, published on 1 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the devcert npm package, when an attacker is able to supply arbitrary input to the certificateFor method

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-1929?

2 open source packages ship an affected version, including devcert. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `devcert` | npm | All versions | 1.2.1 |
| `devcert` | npm | All versions | 1.2.1 |

Products: Devcert Project Devcert.

## How do I fix CVE-2022-1929?

Upgrade devcert to 1.2.1 or later.

## Is CVE-2022-1929 being exploited?

There is no known exploitation of CVE-2022-1929 in the wild and no public exploit code.

## Other vulnerabilities in devcert

- [CVE-2020-8186](https://insights.sbomify.com/CVE-2020-8186/): Injection and Command Injection in devcert (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1929 and fix it if it is affected.

What it is: CVE-2022-1929 is a medium-severity denial of service vulnerability in devcert, published on 1 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-1929 in the wild and no public exploit code.

Affected packages and fixed versions:
- devcert (npm): affected all versions; fixed in 1.2.1
- devcert (npm): affected all versions; fixed in 1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1929/ (Markdown: https://insights.sbomify.com/CVE-2022-1929/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1929
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1929
- OSV: https://osv.dev/vulnerability/CVE-2022-1929

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1929/
Summaries are generated and may contain mistakes; the official description above is the record.
