{"answers":{"affected":"3 open source packages ship an affected version, including eth-account. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-1930 in the wild and no public exploit code.","fix":"Upgrade eth-account to 0.5.9 or later.","what":"CVE-2022-1930 is a medium-severity denial of service vulnerability in eth-account, published on 22 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-1930 and fix it if it is affected.\n\nWhat it is: CVE-2022-1930 is a medium-severity denial of service vulnerability in eth-account, published on 22 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-1930 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- eth-account (PyPI): affected all versions; fixed in 0.5.9\n- eth-account (PyPI): affected all versions; fixed in 0.5.9\n- eth-account (PyPI): affected all versions; fixed in 0.5.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-1930/ (Markdown: https://insights.sbomify.com/CVE-2022-1930/index.md)","id":"CVE-2022-1930","markdown":"https://insights.sbomify.com/CVE-2022-1930/index.md","name":"CVE-2022-1930","record":{"aliases":["GHSA-v65g-f3cj-fjp4","PYSEC-2026-806"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python crypto library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using eth-account by supplying malicious input to the encode_structured_data method.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"JFROG","cpe":[{"product":"eth-account","vendor":"ethereum"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the eth-account PyPI package, when an attacker is able to supply arbitrary input to the encode_structured_data method","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ReDoS in eth-account encode_structured_data function","id":"CVE-2022-1930","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":3,"n_references":1,"next":{"headline":"Incorrect Synchronization in polonel/trudesk","id":"CVE-2022-1931"},"packages":[{"ecosystem":"PyPI","fixed":["0.5.9"],"introduced":["0"],"last_affected":[],"package":"eth-account","purl":null,"source":"GHSA-v65g-f3cj-fjp4"},{"ecosystem":"PyPI","fixed":["0.5.9"],"introduced":["0"],"last_affected":[],"package":"eth-account","purl":"pkg:pypi/eth-account","source":"GHSA-v65g-f3cj-fjp4"},{"ecosystem":"PyPI","fixed":["0.5.9"],"introduced":["0"],"last_affected":[],"package":"eth-account","purl":"pkg:pypi/eth-account","source":"PYSEC-2026-806"}],"prev":{"headline":"Exponential ReDoS in devcert","id":"CVE-2022-1929"},"products":["eth-account"],"published":"2022-08-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["eth-account"]},"summary":"Attackers can cause denial of service in applications using eth-account by supplying malicious input to the encode_structured_data method.","url":"https://insights.sbomify.com/CVE-2022-1930/"}