# CVE-2022-1930: ReDoS in eth-account encode_structured_data function

> Attackers can cause denial of service in applications using eth-account by supplying malicious input to the encode_structured_data method.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-v65g-f3cj-fjp4, PYSEC-2026-806

## What is CVE-2022-1930?

CVE-2022-1930 is a medium-severity denial of service vulnerability in eth-account, published on 22 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the eth-account PyPI package, when an attacker is able to supply arbitrary input to the encode_structured_data method

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-1930?

3 open source packages ship an affected version, including eth-account. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `eth-account` | PyPI | All versions | 0.5.9 |
| `eth-account` | PyPI | All versions | 0.5.9 |
| `eth-account` | PyPI | All versions | 0.5.9 |

Products: Ethereum Eth-Account.

## How do I fix CVE-2022-1930?

Upgrade eth-account to 0.5.9 or later.

## Is CVE-2022-1930 being exploited?

There is no known exploitation of CVE-2022-1930 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1930 and fix it if it is affected.

What it is: CVE-2022-1930 is a medium-severity denial of service vulnerability in eth-account, published on 22 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-1930 in the wild and no public exploit code.

Affected packages and fixed versions:
- eth-account (PyPI): affected all versions; fixed in 0.5.9
- eth-account (PyPI): affected all versions; fixed in 0.5.9
- eth-account (PyPI): affected all versions; fixed in 0.5.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1930/ (Markdown: https://insights.sbomify.com/CVE-2022-1930/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1930
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1930
- OSV: https://osv.dev/vulnerability/CVE-2022-1930

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1930/
Summaries are generated and may contain mistakes; the official description above is the record.
