CVE-2022-1935 Security feature bypass in GitLab

Medium 6.5 Published Updated

Attackers with valid Project Trigger Tokens can bypass IP address restrictions in GitLab EE, allowing unauthorized access from any location.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-1935?

CVE-2022-1935 is a medium-severity vulnerability in Gitlab Gitlab, published on 6 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Incorrect authorization in GitLab EE affecting all versions from 12.0 before 14.9.5, all versions starting from 14.10 before 14.10.4, all versions starting from 15.0 before 15.0.1 allowed an attacker already in possession of a valid Project Trigger Token to misuse it from any location even when IP address restrictions were configured

Weakness: CWE-863

Which versions are affected by CVE-2022-1935?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.0.014.9.5, 14.10.4, 15.0.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-1935?

Upgrade gitlab to a fixed version for your release line: 14.9.5, 14.10.4 or 15.0.1.

Is CVE-2022-1935 being exploited?

There is no known exploitation of CVE-2022-1935 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-1935, GHSA-4h2m-723p-2ww2.

Is CVE-2022-1935 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free