CVE-2022-1940 Cross-site scripting in GitLab

High 7.7 Published Updated

Attackers can execute arbitrary JavaScript in GitLab EE via crafted Jira issues, potentially compromising user accounts.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-1940?

CVE-2022-1940 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 6 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A Stored Cross-Site Scripting vulnerability in Jira integration in GitLab EE affecting all versions from 13.11 prior to 14.9.5, 14.10 prior to 14.10.4, and 15.0 prior to 15.0.1 allows an attacker to execute arbitrary JavaScript code in GitLab on a victim's behalf via specially crafted Jira Issues

Weakness: CWE-79

Which versions are affected by CVE-2022-1940?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.11.014.9.5, 14.10.4, 15.0.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-1940?

Upgrade gitlab to a fixed version for your release line: 14.9.5, 14.10.4 or 15.0.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-1940 being exploited?

There is no known exploitation of CVE-2022-1940 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-1940, GHSA-86mr-824x-hfxf.

Is CVE-2022-1940 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free