# CVE-2022-1941: Out of Memory issue in ProtocolBuffers for cpp and python

> Attackers can cause denial of service in applications using Protocol Buffers by sending specially crafted messages that trigger out-of-memory failures.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2022
- **Updated:** 3 Aug 2024
- **Also known as:** ALSA-2025:7138, AZL-13172, AZL-13174, AZL-25856, AZL-35018, AZL-35125, AZL-35147, AZL-38908, AZL-39031, AZL-39061, CLEANSTART-2026-DG47238, CLEANSTART-2026-PU59944, CLSA-2025-1758039948, CLSA-2026-1770164040, DEBIAN-CVE-2022-1941, GHSA-8gq9-2x98-w8hf, PYSEC-2026-899, RHSA-2025:7138, RLSA-2025:7138, UBUNTU-CVE-2022-1941

## What is CVE-2022-1941?

CVE-2022-1941 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 22 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A parsing vulnerability for the MessageSet type in the ProtocolBuffers versions prior to and including 3.16.1, 3.17.3, 3.18.2, 3.19.4, 3.20.1 and 3.21.5 for protobuf-cpp, and versions prior to and including 3.16.1, 3.17.3, 3.18.2, 3.19.4, 3.20.1 and 4.21.5 for protobuf-python can lead to out of memory failures. A specially crafted message with multiple key-value per elements creates parsing issues, and can lead to a Denial of Service against services receiving unsanitized input. We recommend upgrading to versions 3.18.3, 3.19.5, 3.20.2, 3.21.6 for protobuf-cpp and 3.18.3, 3.19.5, 3.20.2, 4.21.6 for protobuf-python. Versions for 3.16 and 3.17 are no longer updated.

Weakness: CWE-1286 (Improper Validation of Syntactic Correctness of Input)

## Which versions are affected by CVE-2022-1941?

9 open source packages ship an affected version, including protobuf. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `protobuf` | PyPI | All versions | 3.18.3, 3.19.5, 3.20.2, 4.21.6 |
| `protobuf` | PyPI | All versions | 3.18.3 |
| `protobuf` | PyPI | All versions | 3.18.3 |
| `protobuf` | PyPI | From 3.19.0 | 3.19.5 |
| `protobuf` | PyPI | From 3.19.0 | 3.19.5 |
| `protobuf` | PyPI | From 3.20.0 | 3.20.2 |
| `protobuf` | PyPI | From 3.20.0 | 3.20.2 |
| `protobuf` | PyPI | From 4.0.0 | 4.21.6 |
| `protobuf` | PyPI | From 4.0.0 | 4.21.6 |
| `protobuf` | AlmaLinux:9 | All versions | 3.14.0-16.el9 |
| `protobuf-compiler` | AlmaLinux:9 | All versions | 3.14.0-16.el9 |
| `protobuf-devel` | AlmaLinux:9 | All versions | 3.14.0-16.el9 |
| `protobuf-lite` | AlmaLinux:9 | All versions | 3.14.0-16.el9 |
| `protobuf-lite-devel` | AlmaLinux:9 | All versions | 3.14.0-16.el9 |
| `python3-protobuf` | AlmaLinux:9 | All versions | 3.14.0-16.el9 |
| `protobuf` | Red Hat:enterprise_linux:9::appstream | All versions | 0:3.14.0-16.el9 |
| `protobuf-compiler-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:3.14.0-16.el9 |
| `protobuf-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:3.14.0-16.el9 |
| `protobuf-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:3.14.0-16.el9 |
| `protobuf-lite` | Red Hat:enterprise_linux:9::appstream | All versions | 0:3.14.0-16.el9 |
| `protobuf-lite-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:3.14.0-16.el9 |
| `python3-protobuf` | Red Hat:enterprise_linux:9::appstream | All versions | 0:3.14.0-16.el9 |
| `protobuf-compiler` | Red Hat:enterprise_linux:9::crb | All versions | 0:3.14.0-16.el9 |
| `protobuf-compiler-debuginfo` | Red Hat:enterprise_linux:9::crb | All versions | 0:3.14.0-16.el9 |
| `protobuf-debuginfo` | Red Hat:enterprise_linux:9::crb | All versions | 0:3.14.0-16.el9 |
| `protobuf-debugsource` | Red Hat:enterprise_linux:9::crb | All versions | 0:3.14.0-16.el9 |
| `protobuf-devel` | Red Hat:enterprise_linux:9::crb | All versions | 0:3.14.0-16.el9 |
| `protobuf-lite-debuginfo` | Red Hat:enterprise_linux:9::crb | All versions | 0:3.14.0-16.el9 |
| `protobuf-lite-devel` | Red Hat:enterprise_linux:9::crb | All versions | 0:3.14.0-16.el9 |
| `protobuf` | Rocky Linux:9 | All versions | 0:3.14.0-16.el9 |

Products: Debian Debian Linux, Fedoraproject Fedora, Google Protobuf-Cpp, Google Protobuf-Python.

## How do I fix CVE-2022-1941?

Upgrade protobuf to a fixed version for your release line: 3.18.3, 3.19.5, 3.20.2 or 4.21.6.

## Is CVE-2022-1941 being exploited?

There is no known exploitation of CVE-2022-1941 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1941 and fix it if it is affected.

What it is: CVE-2022-1941 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 22 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-1941 in the wild and no public exploit code.

Affected packages and fixed versions:
- protobuf (PyPI): affected all versions; fixed in 3.18.3, 3.19.5, 3.20.2, 4.21.6
- protobuf (PyPI): affected all versions; fixed in 3.18.3
- protobuf (PyPI): affected all versions; fixed in 3.18.3
- protobuf (PyPI): affected from 3.19.0; fixed in 3.19.5
- protobuf (PyPI): affected from 3.19.0; fixed in 3.19.5
- protobuf (PyPI): affected from 3.20.0; fixed in 3.20.2
- protobuf (PyPI): affected from 3.20.0; fixed in 3.20.2
- protobuf (PyPI): affected from 4.0.0; fixed in 4.21.6
- protobuf (PyPI): affected from 4.0.0; fixed in 4.21.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1941/ (Markdown: https://insights.sbomify.com/CVE-2022-1941/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1941
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1941
- OSV: https://osv.dev/vulnerability/CVE-2022-1941

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1941/
Summaries are generated and may contain mistakes; the official description above is the record.
