CVE-2022-1944 Missing authorization in GitLab

Medium 5.4 Published Updated

Developers can access other developers' job terminals in GitLab when the Interactive Web Terminal feature is enabled, allowing unauthorized command execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-1944?

CVE-2022-1944 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 6 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

When the feature is configured, improper authorization in the Interactive Web Terminal in GitLab CE/EE affecting all versions from 11.3 prior to 14.9.5, 14.10 prior to 14.10.4, and 15.0 prior to 15.0.1 allows users with the Developer role to open terminals on other Developers' running jobs

Weakness: CWE-863

Which versions are affected by CVE-2022-1944?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.3.014.9.5, 14.10.4, 15.0.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-1944?

Upgrade gitlab to a fixed version for your release line: 14.9.5, 14.10.4 or 15.0.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2022-1944 being exploited?

There is no known exploitation of CVE-2022-1944 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-1944, GHSA-2wrv-52w9-gffw.

Is CVE-2022-1944 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free