CVE-2022-1962 Stack exhaustion due to deeply nested types in go/parser

Medium 5.5 Published Updated

An attacker can cause a panic and denial of service in applications using the Go parser by providing deeply nested types or declarations.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2022-1962?

CVE-2022-1962 is a medium-severity denial of service vulnerability in Golang Go, published on 9 Aug 2022. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Uncontrolled recursion in the Parse functions in go/parser before Go 1.17.12 and Go 1.18.4 allow an attacker to cause a panic due to stack exhaustion via deeply nested types or declarations.

Weakness: CWE-674

Which versions are affected by CVE-2022-1962?

2 open source packages ship an affected version, including golang and stdlib. It affects 1 product.

PackageAffectedFixed in
golang BitnamiAll versions1.17.12, 1.18.4
stdlib GoAll versions1.17.12, 1.18.4
Linux distribution packages (1)
velero openSUSE:TumbleweedAll versions1.9.2-1.1

Products include Golang Go.

How do I fix CVE-2022-1962?

Upgrade golang to a fixed version for your release line: 1.17.12 or 1.18.4.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-1962 being exploited?

There is no known exploitation of CVE-2022-1962 in the wild and no public exploit code.

All Golang Go vulnerabilities

Sources

Also known as AZL-10530, AZL-78972, AZL-98724, BIT-golang-2022-1962, DEBIAN-CVE-2022-1962, GHSA-6mwq-4j3f-rr3x and 5 more.

Is CVE-2022-1962 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free