CVE-2022-1963 Information disclosure in GitLab
Unauthenticated attackers can determine if a user has enabled two-factor authentication by inspecting the HTML source code.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-1963?
CVE-2022-1963 is a medium-severity vulnerability in Gitlab Gitlab, published on 1 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 13.4 before 14.10.5, all versions starting from 15.0 before 15.0.4, all versions starting from 15.1 before 15.1.1. GitLab reveals if a user has enabled two-factor authentication on their account in the HTML source, to unauthenticated users.
Which versions are affected by CVE-2022-1963?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 13.4.0 | 14.10.5, 15.0.4, 15.1.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-1963?
Upgrade gitlab to a fixed version for your release line: 14.10.5, 15.0.4 or 15.1.1.
Is CVE-2022-1963 being exploited?
There is no known exploitation of CVE-2022-1963 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-1963, GHSA-h743-v64g-4f2g, UBUNTU-CVE-2022-1963.