CVE-2022-1981 Auth bypass in GitLab

Low 2.7 Published Updated

Maintainers can bypass domain allow-list restrictions by inviting groups with non-compliant members, allowing unauthorized access to restricted groups.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-1981?

CVE-2022-1981 is a low-severity authentication bypass vulnerability in Gitlab Gitlab, published on 1 Jul 2022. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An issue has been discovered in GitLab EE affecting all versions starting from 12.2 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1. In GitLab, if a group enables the setting to restrict access to users belonging to specific domains, that allow-list may be bypassed if a Maintainer uses the 'Invite a group' feature to invite a group that has members that don't comply with domain allow-list.

Weakness: CWE-863

Which versions are affected by CVE-2022-1981?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.2.014.10.5, 15.0.4, 15.1.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-1981?

Upgrade gitlab to a fixed version for your release line: 14.10.5, 15.0.4 or 15.1.1.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2022-1981 being exploited?

There is no known exploitation of CVE-2022-1981 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-1981, GHSA-gx2q-25q6-r3h9, UBUNTU-CVE-2022-1981.

Is CVE-2022-1981 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free