CVE-2022-1982 A crafted SVG attachment can crash a Mattermost server
An authenticated attacker can crash the Mattermost server by uploading a crafted SVG attachment, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-1982?
CVE-2022-1982 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 2 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Uncontrolled resource consumption in Mattermost version 6.6.0 and earlier allows an authenticated attacker to crash the server via a crafted SVG attachment on a post.
Weakness: CWE-400
Which versions are affected by CVE-2022-1982?
9 open source packages ship an affected version, including github.com/mattermost/mattermost-server and mattermost. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 5.0.0 | 6.3.8 |
github.com/mattermost/mattermost-server Go | From 5.0.0 | 6.3.8 |
github.com/mattermost/mattermost-server Go | From 6.4.0 | 6.4.3 |
github.com/mattermost/mattermost-server Go | From 6.4.0 | 6.4.3 |
github.com/mattermost/mattermost-server Go | From 6.5.0 | 6.5.1 |
github.com/mattermost/mattermost-server Go | From 6.5.0 | 6.5.1 |
3 more packages
github.com/mattermost/mattermost-server Go | From 6.6.0 | 6.6.1 |
github.com/mattermost/mattermost-server Go | From 6.6.0 | 6.6.1 |
mattermost Bitnami | From 5.0.0 to 6.5.0 | 6.3.8, 6.4.3 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2022-1982?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 6.3.8, 6.4.3, 6.5.1 or 6.6.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-1982 being exploited?
There is no known exploitation of CVE-2022-1982 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as BIT-mattermost-2022-1982, GHSA-gwpf-95jc-63rv.